CC

自然万物都趋向从有序变得无序

0%

HDU 1003 Max Sum

Max Sum

Given a sequence a11,a22,a33......ann, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

思路

状态转移方程dp[i]=max(dp[i-1]+a[i],a[i]);

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;

int main(){
int t;
int cas=0;
scanf("%d",&t);
while(t--){

int n;
scanf("%d",&n);
int m=-1111;
int s=0;
int sx=1,sy=1,temp=1;
for(int i=1;i<=n;++i){
int x;
scanf("%d",&x);
s+=x;
if(s>m){
m=s;
sx=temp;
sy=i;
} if(s<0){
s=0;
temp=i+1;
}
}

printf("Case %d:\n%d %d %d\n",++cas,m,sx,sy);
if(t)
printf("\n");
}
return 0;
}