CC

自然万物都趋向从有序变得无序

0%

LightOJ 1370 Bi-shoe and Phi-shoe

题目链接:点我

题目


Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,
Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题意:

给你一些数的欧拉函数值,我们要求欧拉函数的值大于这些数的值的和,

思路:

欧拉函数打表即可.

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

typedef long long LL;
const int maxn = 1e6+100;
int euler[maxn];
int a[10000+10];

void init(){
for(int i = 1; i< maxn;++i)
euler[i] =i;
euler[1]= 0;
for(int i = 2; i< maxn;++i){
if(euler[i]== i){
for(int j = i; j< maxn;j += i)
euler[j] = euler[j]- euler[j]/i;
}
}
}

int main(){
int n;
init();
int kase = 0;
int t;scanf("%d", &t);
while(t--){
scanf("%d", &n);
for(int i = 1;i <= n;++i)
scanf("%d", &a[i]);
sort(a+1,a+1+n);
LL ans = 0;
int k = 1;
for(int i = 1;i < maxn && k<= n; ++i){
if(euler[i]>=a[k]){
ans += i;
--i;
++k;
}
}
printf("Case %d: %lld Xukha\n", ++kase, ans);
}
return 0;
}