CC

自然万物都趋向从有序变得无序

0%

Eight HDU - 1043

题目链接:点我

题目

The 15-puzzle has been around for over 100 years; even if you don’t know it by that name, you’ve seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let’s call the missing tile ‘x’; the object of the puzzle is to arrange the tiles so that they are ordered as:

1 2 3 4
5 6 7 8
9 10 11 12
13 14 15 x
where the only legal operation is to exchange ‘x’ with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4
5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->
The letters in the previous row indicate which neighbor of the ‘x’ tile is swapped with the ‘x’ tile at each step; legal values are ‘r’,‘l’,‘u’ and ‘d’, for right, left, up, and down, respectively.
Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing ‘x’ tile, of course).
In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three arrangement.

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus ‘x’. For example, this puzzle
1 2 3
x 4 6
7 5 8
is described by this list:
1 2 3 x 4 6 7 5 8

Output

You will print to standard output either the word ``unsolvable’’, if the puzzle has no solution, or a string consisting entirely of the letters ‘r’, ‘l’, ‘u’ and ‘d’ that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.

Sample Input

2  3  4  1  5  x  7  6  8

Sample Output

ullddrurdllurdruldr

题意:

经典的八数码问题,问你要怎样变换才能从初始状态变到目标状态.

思路:

bfs + 康拓展开,紫书的一道例题,只是紫书没有记录路径.稍微变换一个即可

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<string>
#include<algorithm>
#include<queue>
#include<set>
using namespace std;
int dx[4]={-1,1,0,0};
int dy[4]={0,0,-1,1};
struct p
{
int a[9];
};
int last[362880];
int fx[362880];
int fact[9];
int vis[362880];
void init()
{
fact[0]=1;
for(int i=1;i<9;i++) fact[i]=fact[i-1]*i;
}
int codee(p x)
{
int code=0;
for(int i=0;i<9;i++)
{
int cnt=0;
for(int j=i+1;j<9;j++)
if (x.a[j]<x.a[i]) cnt++;
code+=fact[8-i]*cnt;
}
return code;
}
void out(int x)
{
if (last[x]==-1) return;
switch (fx[x])
{
case 0:printf("d");break;
case 1:printf("u");break;
case 2:printf("r");break;
case 3:printf("l");break;
}
out(last[x]);
}
int bfs()
{
p b;
for(int i=0;i<8;i++)
b.a[i]=i+1;
b.a[8]=0;
int ha=codee(b);
last[ha]=-1;
vis[ha]=1;
queue<p> que;
que.push(b);
while(!que.empty())
{
p u=que.front();que.pop();
int hau=codee(u);
int z;
for(z=0;z<9;z++) if (u.a[z]==0) break;
int x=z/3,y=z%3;
for(int i=0;i<4;i++)
{
p v=u;
int tx=x+dx[i],ty=y+dy[i],tz=tx*3+ty;
if (tx>=0&&tx<3&&ty>=0&&ty<3)
{
swap(v.a[z],v.a[tz]);
int haa=codee(v);
if (!vis[haa])
{
fx[haa]=i;
last[haa]=hau;
que.push(v);vis[haa]=1;
}
}
}
}
return 0;
}
int main()
{
char c;
init();
memset(vis,0,sizeof(vis));
bfs();
while(scanf(" %c",&c)!=EOF)
{
p x;
if (c!='x') x.a[0]=c-48;
else x.a[0]=0;
for(int i=1;i<9;i++)
{
scanf(" %c",&c);
if (c!='x')x.a[i]=c-48;
else x.a[i]=0;
}
int code=codee(x);
if (vis[code])
{
out(code);
}
else printf("unsolvable");
printf("\n");
}
return 0;
}