CC

自然万物都趋向从有序变得无序

0%

Bad Hair Day POJ - 3250

题目链接:点我

题目


Some of Farmer John’s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows’ heads.
Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

            =
    =       =
    =   -   =         Cows facing right -->
    =   =   =
    = - = = =
    = = = = = =
    1 2 3 4 5 6 
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!
 Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows, N.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i.

Output

Line 1: A single integer that is the sum of c 1 through cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5

题意:

有一群牛排成一列,每头牛只能看到它前面的比它低的牛,问每头牛能看到的牛的数量的和.

思路:

单调栈.转换一下视角,一只牛能看到多少头牛可以转换为每只牛能被多少头牛看到,那么我们只需要维护一个单调递减的栈即可.

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include<cstdio>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
using namespace std;

int a[80005];

int main()
{
int n;
while(scanf("%d", &n) != EOF){
long long ans = 0;
int top = 1;
for(int i = 1; i <= n; ++ i){
int x;
scanf("%d", &x);
while(top > 0 && a[top] <= x) --top;
ans += top;
a[++ top] = x;
}
printf("%lld\n", ans);
}
return 0;
}