CC

自然万物都趋向从有序变得无序

0%

POJ 2478 Farey Sequence

题目链接:点我

题目


The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn. 

Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

水题:即是求一个数的欧拉函数的前n项和.打表即可.

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 1e6+10;
long long euler[maxn];

void init(){
for(int i = 1; i< maxn;++i)
euler[i] =i;
euler[1]= 0;
for(int i = 2; i< maxn;++i){
if(euler[i]== i){
for(int j = i; j< maxn;j += i)
euler[j] = euler[j]- euler[j]/i;
} euler[i] += euler[i-1];
}
}

int main(){
int n;
init();
while(scanf("%d", &n), n){
printf("%lld\n",euler[n]);
}
return 0;
}