CC

自然万物都趋向从有序变得无序

0%

LightOJ 1245 Harmonic Number (II)

题目链接:点我

题目


I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        res = res + n / i;
    return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 2^31).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386

题意:

如代码所示,求n / i 的前n项和.

思路:

对于本题可以将它转化为,在坐标轴中y=n/x和x=y两条线形成的图形中,类似梯形中的整数点的个数,即为我们要求的,在最后需要减去边长为(int )sqrt(n)正方形的面积,因为它被计算了两次.

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

int main(){
int t;
scanf("%d", &t);
int kase = 0;
while(t--){
int n;
scanf("%d", &n);
long long ans = 0;
int i;
for(i = 1; i <=(int)sqrt(n); ++i)
ans += n/i;
ans *= 2;
ans -=(i - 1)*(i - 1);
printf("Case %d: %lld\n",++kase, ans);
}
return 0;
}