CC

自然万物都趋向从有序变得无序

0%

POJ 2955 - Brackets

Brackets

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.

<!--more-->

no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

题意

给你一串字符串,判断有多少个括号配对

思路

1 类似POJ 1141 的那道括号匹配问题,这里我们只需要转换一下,求最少加上多少个括号就能使所有的括号匹配,然后用总长度减去需要加上的括号,极为匹配的括号,
dp[i][j]表示i道j最少需要加上多少个括号,

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

int const INF=0x3fffffff;
char s[205];
int dp[205][205];

int main(){
while(scanf("%s",s)!=EOF&&strcmp(s,"end")!=0){
memset(dp,0,sizeof(dp));
int len=strlen(s);
for(int i=0;i<len;++i)
dp[i][i]=1;
for(int k=1;k<len;++k)
for(int i=0;i<len-1;++i){
dp[i][i+k]=INF;
if((s[i]=='('&&s[i+k]==')')||(s[i]=='['&&s[i+k]==']'))
dp[i][i+k]=dp[i+1][i+k-1];
for(int j=i;j<i+k;++j)
dp[i][i+k]=min(dp[i][i+k],dp[i][j]+dp[j+1][i+k]);
}
printf("%d\n",len-dp[0][len-1]);
}
return 0;
}