CC

自然万物都趋向从有序变得无序

0%

POJ 2752 Seek the Name, Seek the Fame

题目链接:点我

题目


The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:
Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name. 

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题意:

题意:

给定一串字符串,算出可能的前缀,后缀长度,

思路:

KMP算法,算出 next数组即可,

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;

const int maxn = 4e5+10;
char s[maxn];
int nextt[maxn];
int ans[maxn];

void getnextt(int len){
memset(nextt, 0, sizeof(nextt));
nextt[0] = -1;
int i = 0, j = -1;
while(i < len){
if(j ==- 1 ||s[i] == s[j]){
++i;
++j;
nextt[i] = j;
}else j = nextt[j];
}
}

int main(){
std::ios::sync_with_stdio(false);
while(cin>>s){
int len = strlen(s);
getnextt(len);
int k = 0;
for(int i = len ; nextt[i] != -1; i = nextt[i])
ans[++k] = i;
for(int i = k ; i > 1; --i)
cout<<ans[i]<<' ';
cout<<ans[1]<<endl;
}return 0;
}