CC

自然万物都趋向从有序变得无序

0%

Primitive Roots POJ - 1284 原根, 欧拉函数

题目链接

题目


We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x^i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7.
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p.

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator. 

Output

For each p, print a single number that gives the number of primitive roots in a single line. 

Sample Input

23
31
79

Sample Output

10
8
24

题意:

给你一个奇素数, 求它原根的个数.

思路:

定义:n的原根x满足条件0<x<n,并且有集合{ (x^i mod n) | 1 <= i <=n-1 } 和集合{ 1, ..., n-1 }相等
定理:如果p有原根,则它恰有φ(φ(p))个不同的原根,p为素数,当然φ(p)=p-1,因此就有φ(p-1)个原根.

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

typedef long long LL;
const int maxn = 66666;
int euler[maxn];

void Euler(){
for(int i = 1; i < maxn; ++i)
euler[i] = i;
for(int i = 2; i < maxn; ++i){
if(euler[i] == i){
for(int j = i ; j < maxn; j += i)
euler[j] -= euler[j] / i;
}
}
}

int main(){
Euler();
ios::sync_with_stdio(false);
int n;
while(cin >> n){
cout<<euler[n-1]<<endl;
}return 0;
}