CC

自然万物都趋向从有序变得无序

0%

FatMouse and Cheese HDU - 1078

题目链接:点我

题目

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.
Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input

There are several test cases. Each test case consists of
a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题意:

问老鼠能吃到的最多的奶酪数量,并且每次吃的奶酪数量必须严格递增.

思路:

记忆和搜索(动态规划) ,直接从开始位置爆搜即可,

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;

int w[103][1002];
int dp[103][102];
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};
int n,k;

int dfs(int x, int y){
if(dp[x][y]) return dp[x][y];
int t = 0;
for(int i = 0; i < 4; ++i)
for(int j = 1; j <= k; ++j){
int sx = x + dx[i] * j;
int sy = y + dy[i] * j;
if(sx > 0 && sy > 0 &&sx <= n && sy <= n && w[sx][sy] > w[x][y]){
int tmp = dfs(sx, sy);
t = max(t, tmp);
}
}return dp[x][y] = t + w[x][y];
}

int main(){
while(scanf("%d %d", &n, &k) != EOF && (n != -1 || k != -1)){
for(int i = 1; i <= n; ++i)
for(int j = 1; j <= n;++j)
scanf("%d", &w[i][j]);
memset(dp, 0, sizeof(dp));
printf("%d\n",dfs(1, 1));
}return 0;
}