CC

自然万物都趋向从有序变得无序

0%

LightOJ 1220 Mysterious Bacteria

题目链接:点我

题目


Dr. Mob has just discovered a Deathly Bacteria. He named it RC-01. RC-01 has a very strange reproduction system. RC-01 lives exactly x days. Now RC-01 produces exactly p new deadly Bacteria where x = bp (where b, p are integers). More generally, x is a perfect pth power. Given the lifetime x of a mother RC-01 you are to determine the maximum number of new RC-01 which can be produced by the mother RC-01.

Input

Input starts with an integer T (≤ 50), denoting the number of test cases.

Each case starts with a line containing an integer x. You can assume that x will have magnitude at least 2 and be within the range of a 32 bit signed integer.

Output

For each case, print the case number and the largest integer p such that x is a perfect pth power.

Sample Input

3

17

1073741824

25

Sample Output

Case 1: 1

Case 2: 30

Case 3: 2

题意:

给你一个公式 x=bpx = b ^{p}, 给你一个数x,求最大的p.

思路:

唯一分解定理:x = p1e1p_1^{e_1} * p2e2p_2^{e_2} *p3e3p_3^{e_3} …,那么根据题意所有ans = gcd( e1e_1 ,e2e_2,e3e_3…);而且这里,如果x为负数的话,那么ans一定只能是奇数.

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;

typedef long long LL;
const int maxn = 1e6 + 10;
bool vis[maxn];
int pri[maxn/10];
int k , num = 0;
LL n, ans;
bool flag;
LL a[1000];

void prime(){
memset(vis,false,sizeof(vis));
for(int i = 2; i < maxn; ++i){
if (!vis[i]) pri[++num] = i;
for(int j = 1;j <= num && i *pri[j] < maxn; ++j){
vis[i * pri[j]] = true;
if (i % pri[j] == 0) break;
}
}
}

LL gcd(LL a, LL b){
return b ? gcd(b, a % b) : a;
}

void solve(){
for(int i = 1; i <= num && pri[i] <= (int)sqrt(n); ++i){
int cnt = 0;
while(n % pri[i] == 0){
++cnt;
n /= pri[i];
}
if(cnt) a[++k] = cnt;
if (cnt == 1){
ans = 1;
return ;
}
} if(n > 1) {
ans = 1;
return ;
}
int tmp = a[1];
for(int i = 2; i <= k; ++i){
tmp = gcd( tmp, a[i]);
}
if(flag){//如果n为奇数,那么ans 只能为奇数,
while(tmp % 2 ==0)
tmp /= 2;
}
ans = tmp;
}


int main(){
int t, kase = 0;
prime();
scanf("%d", &t);
while( t--){
scanf("%lld", &n);
flag = false;
if(n < 0){
flag = true;
n = -n;
}
k = 0;
ans = 0;
solve();
printf("Case %d: %lld\n", ++kase, ans);
}
return 0;
}