CC

自然万物都趋向从有序变得无序

0%

LightOJ 1234 Harmonic Number

题目链接:点我

题目


In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

题意:

求调和级数的前n项和

思路:

调和级数求和的公式:ans = log10nlog_{10} n + C + 1.0 / (2 * n); 这里的
C =0.57721566490153286060651209 ,不过这个公式在n毕竟小的时候不准确,所以我们在n比较小的时候直接暴力,n比较大的时候用公式.

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

double C = 0.57721566490153286060651209;
const int maxn = 1e6 + 10;
double a[maxn];

void init(){
a[1] = 1;
for(int i = 2; i <= 1e6; ++i)
a[i] = a[i-1]+ 1.0 / i;
}

int main(){
int t;
init();
scanf("%d", &t);
int kase = 0;
while(t-- ){
int n;
scanf("%d",&n);
printf("Case %d: ", ++kase);
if(n <= 1e6){
printf("%.10f\n", a[n]);
}else {
printf("%.10f\n", log(n) + C + 1.0 / ( 2 * n) );
}
}
return 0;
}