CC

自然万物都趋向从有序变得无序

0%

A Bug's Life HDU - 1829

题目链接:点我

题目


Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

题意:

判断是否有同性恋的行为存在;

思路:

带权并查集或者分组并查集.
先说简单的分组并查集,我们之需要将每次放进来的两个点分别加入两组并查集进行合并,然后判断是否冲突即可,
然后是带权并查集,这个就要稍微麻烦一点,我们需要用权值来维护两只昆虫的性别是否相同,这里我们用0 和 1 来表示两种性别,

带权并查集代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;

int f[2000+10];
int ran[2000+10];
bool flag = false;

int getf(int x){
if(x == f[x]) return x;
int t = getf(f[x]);
ran[x] = (ran[x] + ran[f[x]]) & 1;
f[x] = t;
return t;
}

void Merge(int x,int y){
int t1 = getf(x);
int t2 = getf(y);
if(t1 != t2){
f[t2] = t1;
ran[t2] = (ran[x] + ran[y] + 1) & 1;由于多加如一条边,所以需要加 1 ,
return ;
}
if(ran[x] == ran[y])
flag = true;
}

int main(){
int t;
scanf("%d", &t);
int kase = 0;
while(t--){
int n, m;
scanf("%d %d", &n, &m);
for(int i = 1; i <= n;++i)
f[i] = i,ran[i] = 0;
flag = false;
while(m--){
int x, y;
scanf("%d %d", &x, &y);
if(flag)
continue;
Merge(x,y);
}printf("Scenario #%d:\n",++kase);
if(flag)
printf("Suspicious bugs found!\n");
else printf("No suspicious bugs found!\n");
printf("\n");
}
return 0;
}

分组并查集代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;

int f[2000 * 2+10];
int ran[2000+10];
bool flag = false;

int getf(int x){
if(x == f[x]) return x;
return f[x] = getf(f[x]);
}

void Merge(int x,int y){
int t1 = getf(x);
int t2 = getf(y);
if(t1 != t2)
f[t2] = t1;
}

int main(){
int t;
scanf("%d", &t);
int kase = 0;
while(t--){
int n, m;
scanf("%d %d", &n, &m);
for(int i = 1; i <= n + n;++i)
f[i] = i;
flag = false;
while(m--){
int x, y;
scanf("%d %d", &x, &y);
if(getf(x) == getf(y) || getf(x + n) == getf(y + n))
flag =true;//判断是否已经存在同性恋
if(flag)
continue;
Merge(x,y + n);
Merge(x + n, y);//分别加入并查集中
}printf("Scenario #%d:\n",++kase);
if(flag)
printf("Suspicious bugs found!\n");
else printf("No suspicious bugs found!\n");
printf("\n");
}
return 0;
}