CC

自然万物都趋向从有序变得无序

0%

Combinations LightOJ - 1067

题目链接:点我

题目


Given n different objects, you want to take k of them. How many ways to can do it?
For example, say there are 4 items; you want to take 2 of them. So, you can do it 6 ways.
Take 1, 2
Take 1, 3
Take 1, 4
Take 2, 3
Take 2, 4
Take 3, 4

Input

Input starts with an integer T (≤ 2000), denoting the number of test cases.
Each test case contains two integers n (1 ≤ n ≤ 106), k (0 ≤ k ≤ n).

Output

For each case, output the case number and the desired value. Since the result can be very large, you have to print the result modulo 1000003.

Sample Input

3
4 2
5 0
6 4

Sample Output

Case 1: 6
Case 2: 1
Case 3: 15

题意:

求组合数C(n,k).

思路:

此题的关键在于除法取模的问题,由于模是一个素数,所以我们可以直接由费马小定理得出 
        a / b % mod = a * pow(b, mod -2) % mod;
ps:组合数取模应该也可以用lucas来解决.

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<iostream>
using namespace std;

typedef long long LL;
const int maxn = 1e6 +10;
const int mod = 1e6 + 3;
LL a[maxn];
LL b[maxn];

LL Pow(LL x, int n){
LL base = x;
LL ans = 1;
while(n){
if(n&1) ans =(ans * base ) % mod;
base = base * base % mod;
n = n >> 1;
}
return ans;
}

void init(){
a[0] = 1;
b[0] = 1;
for(int i = 1; i < maxn; ++i){
a[i] =( a[i - 1] * i) % mod;
b[i] = Pow(a[i], mod - 2);
}
}

int main(){
int t;
init();
scanf("%d", &t);
int cas = 0;
while(t--){
int n, k;
scanf("%d %d", &n, &k);
printf("Case %d: %lld",++cas,(a[n] * b[k] % mod )* b[n - k] % mod);
printf("\n");
}
return 0;
}