CC

自然万物都趋向从有序变得无序

0%

Non-negative Partial Sums HDU - 4193

题目链接:点我

题目


    You are given a sequence of n numbers a 0,..., a n-1. A cyclic shift by k positions (0<=k<=n-1) results in the following sequence: a k a k+1,..., a n-1, a 0, a 1,..., a k-1. How many of the n cyclic shifts satisfy the condition that the sum of the fi rst i numbers is greater than or equal to zero for all i with 1<=i<=n?

Input

    Each test case consists of two lines. The fi rst contains the number n (1<=n<=10 6), the number of integers in the sequence. The second contains n integers a 0,..., a n-1 (-1000<=a i<=1000) representing the sequence of numbers. The input will finish with a line containing 0.

Output

    For each test case, print one line with the number of cyclic shifts of the given sequence which satisfy the condition stated above.

Sample Input

3
2 2 1
3
-1 1 1
1
-1
0

Sample Output

3
2
0

题意:

给你一个循环序列,求序列中满足每一项的前缀和都大于等于0的序列的个数.

思路:

序列倍增然后求前缀和,然后维护一个前缀和单调递增的单调队列,

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<cmath>
using namespace std;

const int maxn = 2e6 + 10;
int sum[maxn];
int a[maxn];

int main(){
int n;
while(scanf("%d", &n), n){
for(int i = 1;i <= n; ++i){
scanf("%d", &sum[i]);
sum[n+i] = sum[i];
sum[i] += sum[i-1];
}int ans = 0;
for(int i = n+1; i < n+n; ++i){
sum[i] = sum[i-1] + sum[i];
}int l =1,r = 0;
for(int i = 1; i < n+n; ++i){
while(r>=l && i - a[l]-1>= n)
++l;
while(r >= l && sum[a[r]] >= sum[i])
--r;
a[++r] = i;
if( i >= n && sum[a[l]] - sum[i-n] >=0)
++ans;
}
printf("%d\n",ans);
}
return 0;
}