CC

自然万物都趋向从有序变得无序

0%

How Many Equations Can You Find HDU - 2266

题目链接:点这里

题目

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

Input

Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.

Output

The output contains one line for each data set : the number of ways you can find to make the equation.

Sample Input

123456789 3
21 1

Sample Output

18
1

题意:

    给你一个字符串s和一个数字n,你能有这个字符串能有多少方式组成这个数字

思路:

简单题,直接暴力深搜就可以出答案了

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;

char s[20];
int a[20][20];
int n,m;
int ans;

void init()
{
memset(a,0,sizeof(a));
m=strlen(s);
for(int i=0;i<m;++i){
a[i][i]=s[i]-'0';
for(int j=i+1;j<m;++j){
a[i][j]=a[i][j-1]*10+s[j]-'0';
}
}
}

void dfs(int i,int num)
{
if(i==m){
if(num==n)
++ans;
return ;
}
for(int j=i;j<m;++j){
dfs(j+1,num+a[i][j]);
dfs(j+1,num-a[i][j]);
}
}

int main()
{
while(scanf("%s %d",s,&n)!=EOF){
init();
ans=0;
m=strlen(s);
for(int i=0;i<m;++i){
dfs(i+1,a[0][i]);
}
cout<<ans<<endl;
}
return 0;
}